Linux Kernel Vulnerability that Allows Local Attackers to Escalate Privileges

Linux Kernel Vulnerability

The Security Researcher Alexander Popov found vulnerabilities in the kernel of Linux operating systems that could allow an attacker to escalate local privileges on a victim’s network.

The flaw could allow an attacker to potentially steal data, run administrative commands or install malware on operating systems or server applications.

Popov was able to successfully test an exploit of one of the vulnerabilities on Fedora Server 33, notifying the Linux Foundation, a non-profit consortium designed to standardize support for the open-source Linux system, and other parties through email on February 5.

“The Linux kernel vulnerabilities that I’ve found in AF_VSOCK implementation. I managed to exploit one of them for a local privilege escalation on Fedora Server 33 for x86_64, bypassing SMEP and SMAP.”, says Popov.

According to Popov, the vulnerable kernel modules are race conditions that are present in all major GNU/Linux distributions and automatically load when creating a socket through the AF_VSOCK core, which is designed to communicate between guests virtual machines and their host.

Popov mentioned in the email that he had already developed a patch and followed responsible disclosure guidelines throughout the process.

Privilege Escalation Vulnerability

Privilege escalation vulnerabilities are system flaws that grant a malicious user excessive or wrong permissions after they have authenticated themselves. These are distinct from session hijacking vulnerabilities that allow an attacker to impersonate another user.

Privilege escalation vulnerabilities are considered dangerous because of the level of control they can give an attacker within a victim network. 

RiskSense, Inc., classifies in a recent report that “Privilege escalation along with remote code execution as the two types of vulnerabilities that significantly increases the risk to an organization.”

Popov said that he had already developed a patch and submitted his findings to the National Institute of Standards and Technologies’ National Vulnerability Database, which developed them into CVE-2021-26708.

The vulnerabilities received a 7.0 out of 10 for severity by the Common Vulnerability Scoring System.

The researcher has found two other privilege escalation vulnerabilities in Linux kernels,

CVE-2019-18683 in 2019, Exploiting a Linux kernel vulnerability in the V4L2 subsystem and CVE-2017-2636 in 2017, Exploit the race condition in the n_hdlc Linux kernel driver bypassing SMEP.

Finally, such vulnerabilities are becoming more and more popular among cybercriminals and security researchers, with more than 25% of newly published Common Vulnerabilities and Exposure (CVE) records this past year containing some component of privilege escalation or remote code execution.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity, and hacking news updates.

Also Read

NSA Revealed A Russian APT28 Hackers Made Previously Undisclosed Stealthy “Drovorub” Linux Malware

BootHole Vulnerability Affects Millions of Windows and Linux Systems – Allows Attackers to Install Stealthy Malware


Source: GBHackers

Leave a Reply