BadAlloc – Microsoft Warns of Multiple Vulnerabilities That Affects Wide Range of IoT & OT Devices

BadAlloc – Microsoft Warns of Multiple Vulnerabilities That Affects Wide Range of IoT & OT Devices

In a regular analysis, the security researchers of Microsoft from “Section 52,” it’s an Azure Defender for IoT research group have detected nearly 25 CVE vulnerabilities that are continuously affecting a wide range of Internet-connected devices later that can be used to execute arbitrary code remotely.

However, these vulnerabilities are affecting IoT devices, not only this, but the vulnerabilities are also affecting industrial equipment that is specifically used in industrial, medical, and corporate networks. 

After investigating all these vulnerabilities, the security analysts affirmed that these vulnerabilities are collectively known as BadAlloc.

The vulnerabilities are occurring problems such as they are providing an opportunity to bypass all the security mechanisms and easily execute malicious code as per their operation.

BadAlloc used vulnerable memory functions to run malicious code

The security researchers from Microsoft have asserted a detailed summary of BadAlloc, and as per their report, BadAlloc errors happen because of several “memory allocation implementations which have been built for so many years, and they are the part of IoT devices and firmware.

All the CVE vulnerabilities that have been detected were stemmed from the continuous usage of vulnerable memory functions like realloc, valloc, malloc, calloc, pvalloc, memalign and many more.

And as we said above that these vulnerabilities occur due to memory allocation implementation, that’s why the implementations were written as a part of IoT devices throughout the whole year.

If this validation does not occur, then the hackers could easily exploit the vulnerable memory allocation functions to perform the planned operation.

Devices affected

After an investigation, the experts have listed a full list of devices that have been affected by these vulnerabilities, and here they are mentioned below:-

  • Amazon FreeRTOS, Version 10.4.1
  • Apache Nuttx OS, Version 9.1.0
  • ARM CMSIS-RTOS2, versions prior to 2.1.3
  • ARM Mbed OS, Version 6.3.0
  • ARM mbed-uallaoc, Version 1.3.0
  • Cesanta Software Mongoose OS, v2.17.0
  • eCosCentric eCosPro RTOS, Versions 2.0.1 through 4.5.3
  • Google Cloud IoT Device SDK, Version 1.0.2
  • Linux Zephyr RTOS, versions prior to 2.4.0
  • MediaTek LinkIt SDK, versions prior to 4.6.1
  • Micrium OS, Versions 5.10.1 and prior
  • Micrium uCOS II/uCOS III Versions 1.39.0 and prior
  • NXP MCUXpresso SDK, versions prior to 2.8.2
  • NXP MQX, Versions 5.1 and prior
  • Redhat newlib, versions prior to 4.0.0
  • RIOT OS, Version 2020.01.1
  • Samsung Tizen RT RTOS, versions prior 3.0.GBB
  • TencentOS-tiny, Version 3.1.0
  • Texas Instruments CC32XX, versions prior to 4.40.00.07
  • Texas Instruments SimpleLink MSP432E4XX
  • Texas Instruments SimpleLink-CC13XX, versions prior to 4.40.00
  • Texas Instruments SimpleLink-CC26XX, versions prior to 4.40.00
  • Texas Instruments SimpleLink-CC32XX, versions prior to 4.10.03
  • Uclibc-NG, versions prior to 1.0.36
  • Windriver VxWorks, prior to 7.0

Mitigations

The users must follow the mitigations that the security researchers have provided, and here they are:-

  • Remember to apply the most recent updates.
  • Always keep in mind that the affected devices are not accessible from the Internet.
  • Decrease the network exposure for all the available control system devices and systems.
  • Always use secure methods and techniques such as Virtual Private Networks (VPNs).

Apart from this, the security researchers have not yet found any available exploits for these errors but they have claimed that they are doing their homework, and will surely find them in the coming weeks or months.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity, and hacking news updates.


Source: GBHackers

Leave a Reply